Polestar Forum banner
1 - 20 of 37 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
I received my Polestar 2 a couple of weeks ago. I noticed that the air conditioner is weak. Despite fan at full it struggles to achieve the cooling to the desired setting. I am wondering if there is a problem with my car or if this is how it is built.
 

·
Registered
Joined
·
133 Posts
These threads may touch on the same topic. Seems like there's been some updated parts for remedying the issue, no word on whether it worked.


 

·
Registered
Joined
·
225 Posts
I received my Polestar 2 a couple of weeks ago. I noticed that the air conditioner is weak. Despite fan at full it struggles to achieve the cooling to the desired setting. I am wondering if there is a problem with my car or if this is how it is built.
Do an infotainment reset to see if it goes back to normal flow. If not, take it off auto climate and use manual, then adjust to your liking. One of those should solve your issue.
 

·
Super Moderator
Joined
·
2,365 Posts
First thing I'd do is bring up the AC settings on the screen and do a long press of the AUTO button. This resets everything to sane settings.

Now, don't change anything at all except adjusting the temperatures at the bottom of the screen, or maybe moving the 'fan' setting if you want more airflow. Don't use the right hand most setting of the fan speed, nor set the temperatures to 'LO' as that defeats the fully automatic climate control.

If it still misbehaves, then you have a fault and should get it booked in.

The performance of the system is excellent - I've never had an issue with it in 21 months. We had a 'heat wave' here in the UK a couple of weeks ago where temperatures exceeded 40C and it was still fine even in that.
 

·
Registered
non PP - Snow - Ordered Sep 20 - Delivery 01 Dec 20
Joined
·
143 Posts
When it's working fine I find it excellent. But at least once every couple of months I have to to a system reset as the temperature bears no resemblance to the setting. But once that rest is done it's back to operating perfect.
 

·
Registered
Joined
·
464 Posts
I'd love to be able to disable the noisy upper vents while also using AUTO. There needs to be auto fans on the vents we choose to maintain temp but automatically adjusting fan speed.
The whole point of Auto is you set the temperature and the car does everything else - closing and opening stuff manually affects the flow and therefore changes what internal temperature you’ll get.

No, I have no idea why there are different strengths to ‘Auto’ either…
 

·
Registered
2022 LRSM Thunder/Slate/Plus/Hitch
Joined
·
1,473 Posts
You mean different strengths as different fan speeds in AUTO, I assume? … well, the way I look at it is that AUTO means to get automatically to the set temp, the fan speed rate dictates how quickly you desire to get to that set temp, at the expense of higher noise.
 

·
Registered
Joined
·
9 Posts
You should be able to choose which bands are being used to hold the temperature while the fan speed is automatically adjusted. As of now, the only way to have an automatic temp is to also have all three fan zones activated. The upper fan is very noisy so I would rather keep that one off.
 

·
Registered
2022 LRSM Thunder/Slate/Plus/Hitch
Joined
·
1,473 Posts
Hmm … Maybe your upper fan is not operating properly? I am on middle fan speed and 23C and barely can hear the fan once the car is initially cooled down
 

·
Registered
Joined
·
464 Posts
You mean different strengths as different fan speeds in AUTO, I assume? … well, the way I look at it is that AUTO means to get automatically to the set temp, the fan speed rate dictates how quickly you desire to get to that set temp, at the expense of higher noise.
The Polestar Climate control doesn’t work like that though. In the Polestar (and my Volvo) the fan speed doesn’t change to a lower ‘set’ speed once it gets there, it just maintains the higher ‘set’ speed which is a complete nonsense. It does slow down (obviously) but maintains a higher level of intensity if on an upper setting.

Climate control should be simple - ‘Set and Forget’, yet if it’s really hot I find myself going to the upper option in ‘auto’ then turning it back onto the middle one after 5 minutes - just give me the best way of hitting the temperature I’ve set, it should be that simple.
 

·
Registered
2022 LRSM Thunder/Slate/Plus/Hitch
Joined
·
1,473 Posts
I guess, I am not seeing the behaviour you are describing in my vehicle….maybe because I have it set to the middle, 23C and never ever put touch it. I do use parking conditioning or pre-conditioning often, so when I get to the car it’s conditioned…no need to ever go to max. In the beginning.
 

·
Registered
Joined
·
49 Posts
We had four people in the Polestar 2 this last week, temps were upper 90's and humid. My wife and sister inlaw were in the back seat, both complained it was hot and not enough airflow. Front seats my brother and I were fine. I turned up the fan speed and was actually cold in the front, but in the back they were still warm. Anyone else have complaints about amount of airflow in the back seats?
 

·
Super Moderator
Joined
·
2,365 Posts
Yep. It's crap - even in the mild UK weather. There's no dedicated blower fan for the rear - it's just tapped off the front.

The only thing you can do to improve airflow in the back is closing the side vents in the front.

They had opened the vents in the back? I appreciate it's a stupid question...
 

·
Registered
Joined
·
464 Posts
I guess, I am not seeing the behaviour you are describing in my vehicle….maybe because I have it set to the middle, 23C and never ever put touch it. I do use parking conditioning or pre-conditioning often, so when I get to the car it’s conditioned…no need to ever go to max. In the beginning.
I precondition too although prefer it cooler - 20c. However I don’t precondition if it’s just been left for an hour or two at which point I’d expect the car to work it out rather than have me set how much ‘auto’ I want (auto should be auto, the clue is in the title!)
 

·
Super Moderator
Joined
·
2,365 Posts
I have no problems with it - works as expected for me. I leave my fan speed one notch to the right of centre, and leave the temp control set at 19/20C.

I don't think I've fiddled with any of the settings in twenty odd months.

My only niggle, and this sounds insane, is that I wish the temp settings went up in half degree increments. I'd prefer 19.5...
 
1 - 20 of 37 Posts
Top