Polestar Forum banner
1 - 10 of 10 Posts

·
Registered
Joined
·
436 Posts
Discussion Starter · #1 ·
Whilst playing around this morning I noticed something strange. When I had tried to reset the trip etc on DP it hadn't reset the mileage so was giving silly readings. I ended up clearing the cache which solved it.

Settings
System
Storage
Other apps
Driver performance
Clear cache (up at the top)

However after coming back to it after a few minutes noticed that even though I was stationary I had managed to travel at av. speed of 1.9mph but gone nowhere.

Any ideas? Perhaps @ProfessorCook can give his opinion or is it in a parallel universe?

20201216_093621_resized.jpg
 

·
Super Moderator
Polestar 2, Midnight (blue), charcoal interior, non-PP
Joined
·
2,888 Posts
I suspect this is dodgy GPS reception where it occasionally thinks it's a little distance away, and then comes back again. Over a period of such small jumps, it adds up to a noticeable distance...
 

·
Registered
Joined
·
436 Posts
Discussion Starter · #3 ·
I suspect this is dodgy GPS reception where it occasionally thinks it's a little distance away, and then comes back again. Over a period of such small jumps, it adds up to a noticeable distance...
Maybe. Just successfully done the OTA update. DP screen after update!
20201216_112757_resized.jpg
I could have sworn the car didn't move but it was going fast!
 

·
Super Moderator
Polestar 2, Midnight (blue), charcoal interior, non-PP
Joined
·
2,888 Posts
Yep that's a classic where it's not clever enough to realise that the first GPS location it receives may be all zeros which is somewhere in the Atlantic Ocean, if I remember correctly!
 

·
Super Moderator
Polestar 2, Midnight (blue), charcoal interior, non-PP
Joined
·
2,888 Posts
The NMEA output over the serial link from a GPS receiver may well show a string of zeros before it gets a lock, but one of these zeros indicates that it doesn't have a lock yet ;) so it depends on how well the software is implemented (as always...).
 

·
Registered
Oct '20 / VIN47xx. Void, Slate, 20"
Joined
·
554 Posts
That app has always given pure garbage figures for me.
 

·
Super Moderator
Polestar 2, Midnight (blue), charcoal interior, non-PP
Joined
·
2,888 Posts
I doubt NMEA is used, but I'm with you that the software would need to interprete the valid flag correctly ;)
You might be surprised - it's probably part of a standalone module that does the 4G, Bluetooth and GPS/GNSS in one, and it just listens in on a (virtual) serial port...
 

·
Super Moderator
Joined
·
1,397 Posts
My guess as well, but most likely the protocol is not NMEA, but rather something more powerful, bidirectional like the uBlox protocol or whatever manufacturer is used. Huawei maybe 😂
 
1 - 10 of 10 Posts
Top