Polestar Forum banner
1 - 20 of 53 Posts

· Registered
Joined
·
12 Posts
Discussion Starter · #1 · (Edited)
Sorry if this has been asked before but I searched the forum and couldn’t find an answer.

I just purchased the performance upgrade to get the extra HP. How long did it take for you guys to see the download upgrade on your cars?

edit: For anyone wondering mine took about 4-6 days. Ordered Friday and got it the next week. Polestar uploads it manually so I don’t count the weekends.
 

· Registered
'22 P*2 LRDM | Midnight | Barley | Plus | Pilot | Performance + Performance Software Upgrade
Joined
·
154 Posts
Do a search of this forum; it's pretty well documented.

Short Answer: be patient
 
  • Like
Reactions: Nick_Arin

· Registered
'22 P*2 LRDM | Midnight | Barley | Plus | Pilot | Performance + Performance Software Upgrade
Joined
·
154 Posts
If you scour the "Performance Upgrade" threads, the gory details are all there spread over multiple threads.

If memory serves me (and it is generally does not), it took 2-3 days from purchase to notice the download. Once the OTA update was finished, it seemed to be another day or two before the Performance App changed to show 0-60 time, and the Polestar App showed the upgrade under "Specifications."

It all seemed to take a very long time. My unsolicited advice is "be patient."
 
  • Like
Reactions: HecD

· Registered
Joined
·
12 Posts
Discussion Starter · #6 ·
If you scour the "Performance Upgrade" threads, the gory details are all there spread over multiple threads.

If memory serves me (and it is generally does not), it tool 2-3 days from purchase to notice the download. Once the OTA update was finished, it seemed to be another day or two before the Performance App changed to show 0-60 time, and the Polestar App showed the upgrade under "Specifications."

It all seemed to take a very long time. My unsolicited advice is "be patient."
Patience it is then! Good to know we are all in the same boat though.
 

· Registered
P2, Snow, Slate, PP, Hitch, Nextbase Dashcam, 20% Tint, Polestar, give us more regen. breaking!
Joined
·
788 Posts
Also you may have to check the porformance app in your car to see if the launch option is there. My car installed the software without any prompt or notice at all. Didn't know it was active until I started driving the car harder.
 

· Registered
2023 P2 LR AWD Magnesium
Joined
·
5 Posts
Sorry if this has been asked before but I searched the forum and couldn’t find an answer.

I just purchased the performance upgrade to get the extra HP. How long did it take for you guys to see the download upgrade on your cars?
I ordered it earlier this month and it took about one week for the OTA update to appear. Then, after I installed it, it took two full days for the change to show up in my phone app, the car launch app, and my online account.
 

· Registered
2022 PoleStar 2 - Dual Motors - Void
Joined
·
984 Posts
It was two weeks, I ordered mine in the beginning of January and got it after ~7 days.
^^ As this post stated, two weeks. I got mine exactly two weeks after placing the order ^^
 

· Registered
Joined
·
344 Posts
Also you may have to check the porformance app in your car to see if the launch option is there. My car installed the software without any prompt or notice at all. Didn't know it was active until I started driving the car harder.
You mean you never had to click anything at all on the touch screen in order to load the performance upgrade? I don’t think I have heard of that before.
 

· Registered
2022 PoleStar 2 - Dual Motors - Void
Joined
·
984 Posts
You mean you never had to click anything at all on the touch screen in order to load the performance upgrade? I don’t think I have heard of that before.
For me it was an OTA update that popped up. Installed it the same way I've done all others, click install, lock the car and walk away for an hour
 

· Registered
P2, Snow, Slate, PP, Hitch, Nextbase Dashcam, 20% Tint, Polestar, give us more regen. breaking!
Joined
·
788 Posts
You mean you never had to click anything at all on the touch screen in order to load the performance upgrade? I don’t think I have heard of that before.
I installed 2.4 right about that same time. I wonder if it piggybacked on that install. No I did not have to take any action to activate the power upgrade.
 

· Registered
2022 PoleStar 2 - Dual Motors - Void
Joined
·
984 Posts
How does car and app show it? I've had it installed about a month and the only thing that shows is that I have P2.4
 

· Registered
Joined
·
34 Posts
Sharing my experience: I've successfully received OTA's at least 3 times prior. Last update was P2.2 and I had been stuck there for a long time. I was starting to wonder if my TCAM had decided to ignore the cloud. Meanwhile, I decided I'd order the performance software on Jan 12. On the 16th, I received a software update notification. It failed to install a couple of times but quite possibly due to my impatience, unlocking the car and checking on it. The error message was that I needed at least 40% battery to install but I was at 56%. I tried charging but it wouldn't let me, never completing the handshake. Finally left it overnight (unplugged) and woke up on the 17th to P2.4 with a nice green checkmark indicating successful install! But no update to the Performance App nor any other indication that the performance software loaded. Today my online account showed the power upgrade and so I went to check the car for any new updates - nothing. I decided to uninstall and re-install the Performance App. Voila... 0-60 timer activated.

Initial driving impressions... brings back memories of old muscle car days of second gear burnouts! :devilish: Geezus... cruising at 60-70km/h and punching the throttle will invoke front tire spin! I'm running snows and it's currently 6C outside with ever so slightly damp road surfaces. Punching it from 80-90km/h feels like a slingshot. This is most definitely money well spent! Can't wait to get the summers back on for some real fun.
 

· Registered
2022 PoleStar 2 - Dual Motors - Void
Joined
·
984 Posts
If you go to Specifications in the Polestar app it will show that the PSU was installed. On the car, you'll see a button for Launch Control in the Performance app.
Yes, I saw that this morning! Thanks!
 
1 - 20 of 53 Posts
Top