Polestar Forum banner

1 - 17 of 17 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter #1
I have a Rolec charger installed at work, if I use the type 2 to type 2 cable provided by Polestar it does not work, however if I use my friends cable from his BMW330e it charges fine, has anyone else had any similar problems? or solutions even?
 

·
Registered
Joined
·
11 Posts
Discussion Starter #7

·
Registered
Joined
·
11 Posts
Discussion Starter #8

·
Registered
Joined
·
1,073 Posts
It should work but you'll only get 3.6kW ... why it's not working at all is because the Rolec needs to have a software update.

As others mentioned to get the max 7kW You'll need a 32A Cable, either Single phase or Three Phase.
 

·
Registered
Joined
·
11 Posts
Discussion Starter #10
It should work but you'll only get 3.6kW ... why it's not working at all is because the Rolec needs to have a software update.

As others mentioned to get the max 7kW You'll need a 32A Cable, either Single phase or Three Phase.
How do I get software update for Rolec?
 

·
Registered
Joined
·
590 Posts
If it was delivering 32A to another vehicle you should get the same from the Rolec. For example we have got 32A (notional) from a Podpoint into both a Tesla 3 and an Ioniq. Both are type 2 like the P2, We also have a Rolec type 1 for our Ampera, which although 32A only delivers what the Ampy can draw.
Some home chargers only rate at 16A (ish)
 

·
Registered
Joined
·
94 Posts
Understood. Rolec has been 'hanging loose' unused to date, as the Polestar will be my first BEV when delivered on 3rd December, so no 'previous' to refer to.
 
1 - 17 of 17 Posts
Top